Páginas sobre el tema:   < [1 2]
MemoQ 8.+ performance - scrolling up and down oh so tortuously slow
Autor de la hebra: Georgios Tziakos

Alex Tsybulski
Belarús
Local time: 20:26
chino al ruso
+ ...
Video 2 May 8, 2019

Georgios Tziakos wrote:
hi Alex,
Can you please try this on a file where each string is only 1-2 words and let us know how it goes? (but make sure it has a loooot of individual strings).


Sure, here it is:
https://youtu.be/nB4qhuPvGNU


 

Michael Beijer  Identity Verified
Reino Unido
Local time: 17:26
Miembro 2009
neerlandés al inglés
+ ...
what's causing it? May 8, 2019

I agree that there is something very wrong here. Let's hope that if we make enough noise the developers will fix it, or at least try to.

I wonder if it's something related to graphics cards/engines on Windows. I'll play around a bit with the two different graphics cards on my laptop and see if it makes any difference.

Anyone know what memoQ is coded in, .NET?

Incidentally, a bit of a workaround is to use Page up / Page down, which works quite a bit
... See more
I agree that there is something very wrong here. Let's hope that if we make enough noise the developers will fix it, or at least try to.

I wonder if it's something related to graphics cards/engines on Windows. I'll play around a bit with the two different graphics cards on my laptop and see if it makes any difference.

Anyone know what memoQ is coded in, .NET?

Incidentally, a bit of a workaround is to use Page up / Page down, which works quite a bit better/faster than scrolling on my system.

Michael
Collapse


Linh Nguyen
 

Michael Beijer  Identity Verified
Reino Unido
Local time: 17:26
Miembro 2009
neerlandés al inglés
+ ...
another little tip/workaround to speed up scrolling May 8, 2019

Btw, memoQ's scrolling problem is also being discussed @ https://www.proz.com/forum/memoq_support/238642-memoq_scrolling.html

...where someone also posted this interesting/useful nbit of info:

‘Note that you can hold SHIFT+WHEEL to scroll faster with the mouse though.’


 

Alex Tsybulski
Belarús
Local time: 20:26
chino al ruso
+ ...
Yes, but May 8, 2019


‘Note that you can hold SHIFT+WHEEL to scroll faster with the mouse though.’

Yep, it works. And i've been using it this way for quite a long lime. But it is not the solution: i need the precise scrolling (not the whole page at once) and exact sensitivity (when it scrolls exactly the same amount of rows as in the rest apps and stops moving right at the same moment when i stop the wheel).

It drops my productivity badly.


Linh Nguyen
 

Alex Tsybulski
Belarús
Local time: 20:26
chino al ruso
+ ...
GPUs May 8, 2019


I wonder if it's something related to graphics cards/engines on Windows.

I've switched from Nvidia to AMD recently - no changes.
The same problem was on Win 7 (it is Win 10 now).
Was about to disable integrated GPU (Intel) in BIOS (who knows..), but there's no such option on my motherboard.

memoQ uses .NET, i have the latest 4.7.2 installed.

I'm planning to upgrade my RAM from 8 to 16GB in a couple of weeks, we'll see.


 

Georgios Tziakos  Identity Verified
España
Miembro 2011
inglés al griego
+ ...
PERSONA QUE INICIÓ LA HEBRA
RAM upgrades did not help me May 9, 2019

Hi Alex,

Unless you see your RAM on task manager being topped, then I don't think RAm will help you, but it's not a bad investment anyway. This problem looks very very specific though, it's odd. It does look like your MemoQ is struggling a bit graphically, although this might just be my impression from the video.

Since this is an offline project, it has nothing to do with servers or TMs either.

Have you contacted Kilgray directly through email? They do res
... See more
Hi Alex,

Unless you see your RAM on task manager being topped, then I don't think RAm will help you, but it's not a bad investment anyway. This problem looks very very specific though, it's odd. It does look like your MemoQ is struggling a bit graphically, although this might just be my impression from the video.

Since this is an offline project, it has nothing to do with servers or TMs either.

Have you contacted Kilgray directly through email? They do respond, although I haven't had any luck in them actually solving any issues so far.

Also, what MemoQ version are you using? Sorry If you mentioned it already and I cannot find it. If you are using the latest one, please try 2014R2 and 2015. 2014R2 is the version of choice for me, when it can be used, as it's MUCH smoother in every day. Might be interested to check whether different builds still have the scrolling issue, because that might imply it's a specific interaction with your computer that's causing the issue (instead of some versions having bad code).

Best,
Georgios
Collapse


Alex Tsybulski
 

Ekhangel
Local time: 18:26
Bit BS Jun 25

Thomas T. Frost wrote:

No, you don't need 32 GB today. Right now I'm using 22% of it, but systems' and applications' resource requirements keep increasing, so I just wanted a configuration that is likely to last for many years. 8 GB would seem a bit limited today, but with 16 GB, you should be fine for quite a while too.

It's difficult to say what is causing your performance problem.


I work on a 4 GB RAM Surface i5 and I can tell you it's all down to software optimization and proper coding rather than RAM consumption. On some occasions everything works flawlessly and on others everything slows down, and it has nothing to do with the number of applications opened. It's just the coding of MemoQ that is messed up. The app scrolls super slow. As a matter of fact, scrolling in Trados 2019 is also more problematic compared to 2011 (a bit slower, tends to lag or show some artifacts + no touch scroll support).

The programming environment of today seems hell for many developers.


Georgios Tziakos
 

Evergray
Federación Rusa
Local time: 22:26
same here Jul 28

Did anyone manage to find a solution for the slow scrolling problem?

I'm having the same issue. And it happens only in Memoq.


 

Georgios Tziakos  Identity Verified
España
Miembro 2011
inglés al griego
+ ...
PERSONA QUE INICIÓ LA HEBRA
Sole solution: go back to 2014R2, maybe 2015 Jul 28

I am now writing from my monster AMD 3700x, 16 GB 3600 mHz RAM, etc. etc. Let's just say, this is defintely bad coding, like Ekhangel said. 2015 works better, and 2014 even faster. Using 2015 is my compromise solution since it still gets some more comprehensive autocomplete features. I don't see anything on MemoQ 9 making it worth my time as a fast-typing professional translator. Like many other software developers, Kilgray obviously seems to care more about pretending they are improving their ... See more
I am now writing from my monster AMD 3700x, 16 GB 3600 mHz RAM, etc. etc. Let's just say, this is defintely bad coding, like Ekhangel said. 2015 works better, and 2014 even faster. Using 2015 is my compromise solution since it still gets some more comprehensive autocomplete features. I don't see anything on MemoQ 9 making it worth my time as a fast-typing professional translator. Like many other software developers, Kilgray obviously seems to care more about pretending they are improving their software, while failing at the most important and basic metric, its fluid performance.

[Edited at 2020-07-28 16:12 GMT]
Collapse


Linh Nguyen
Neil Ashby
 

Timothy Barton
Local time: 19:26
francés al inglés
+ ...
Active row? Aug 18

Georgios Tziakos wrote:

I am now writing from my monster AMD 3700x, 16 GB 3600 mHz RAM, etc. etc. Let's just say, this is defintely bad coding, like Ekhangel said. 2015 works better, and 2014 even faster. Using 2015 is my compromise solution since it still gets some more comprehensive autocomplete features. I don't see anything on MemoQ 9 making it worth my time as a fast-typing professional translator. Like many other software developers, Kilgray obviously seems to care more about pretending they are improving their software, while failing at the most important and basic metric, its fluid performance.

[Edited at 2020-07-28 16:12 GMT]


I've had similar issues. Switching off "Active row - In the middle" and selecting "Anywhere" seems to help, but then, annoyingly, you have to scroll if you want to see the context of the sentence you're translating. I'd like an option where MemoQ doesn't try to put the active row in the middle constantly (i.e. adjusting everything when you type to the end of a line), but only when you validate a row (or even only when you can't see the row below the working row).


 

Georgios Tziakos  Identity Verified
España
Miembro 2011
inglés al griego
+ ...
PERSONA QUE INICIÓ LA HEBRA
'Active row' Doesn't seem to help, will try in empty project Aug 18

Hi Timothy,

Thanks so much for your suggestion. I only have completed tasks at the moment, so I am not sure I could practically see a difference, if there were any. I'll try again in my next task

Changing my settings from Power saver or Balanced to Ultimate performance seems to improve things ever-so-slightly, but we're talking about having some ridiculous computing/data processing power available here, e
... See more
Hi Timothy,

Thanks so much for your suggestion. I only have completed tasks at the moment, so I am not sure I could practically see a difference, if there were any. I'll try again in my next task

Changing my settings from Power saver or Balanced to Ultimate performance seems to improve things ever-so-slightly, but we're talking about having some ridiculous computing/data processing power available here, even in "power saver" mode.

Georgios
Collapse


 

Evergray
Federación Rusa
Local time: 22:26
2015 has scroll issues too Sep 2

Georgios Tziakos wrote:

I am now writing from my monster AMD 3700x, 16 GB 3600 mHz RAM, etc. etc. Let's just say, this is defintely bad coding, like Ekhangel said. 2015 works better, and 2014 even faster. Using 2015 is my compromise solution since it still gets some more comprehensive autocomplete features. I don't see anything on MemoQ 9 making it worth my time as a fast-typing professional translator. Like many other software developers, Kilgray obviously seems to care more about pretending they are improving their software, while failing at the most important and basic metric, its fluid performance.

[Edited at 2020-07-28 16:12 GMT]


I tried to install version 7.8.3 (2015) and the scroll issue can be seen even there.
Windows 10. AMD 6300, 16 GB RAM, NVidia 1650, SSD.
At the same time the actual version works better (at least it has no scrolling issues) on my old, poor perfomance laptop.
I guess the issue is specific, that is true. But I've got no idea how to fix it...


 

Timothy Barton
Local time: 19:26
francés al inglés
+ ...
Caused by Firefox? Sep 20

Georgios Tziakos wrote:

MemoQ is getting so slow when you scroll up or down the strings in Editor that it basically stutters?


Do you use Firefox? I've found that the slow scrolling magically sorts itself out within about 30 seconds of closing Firefox. If I re-open Firefox, it slows down again. I'm reluctantly considering looking for a new browser if I can't find a fix.

From what I've been reading, it seems that recent (i.e. the past few years) Firefox versions don't work very well with NVidia graphics cards and slow everything down. I've read that rolling back the NVidia driver might help, but haven't tried it yet.


 

Georgios Tziakos  Identity Verified
España
Miembro 2011
inglés al griego
+ ...
PERSONA QUE INICIÓ LA HEBRA
Firefox being open doesn't seem to affect anything Sep 20

Timothy Barton wrote:

Georgios Tziakos wrote:

MemoQ is getting so slow when you scroll up or down the strings in Editor that it basically stutters?


Do you use Firefox? I've found that the slow scrolling magically sorts itself out within about 30 seconds of closing Firefox. If I re-open Firefox, it slows down again. I'm reluctantly considering looking for a new browser if I can't find a fix.

From what I've been reading, it seems that recent (i.e. the past few years) Firefox versions don't work very well with NVidia graphics cards and slow everything down. I've read that rolling back the NVidia driver might help, but haven't tried it yet.


Thank you, Timothy. It doesn't seem to change anything for my desktop client, which is now version 9.3.

Anyway, my conclusions so far:

1) A very powerful computer set on at least Balanced or stronger power modes does help with scrolling speed/stuttering/bad refresh rates, as well as seamless flow while typing (otherwise there are keystrokes that seem to be missed by MemoQ, resulting in typos and letters swapping position, extremely annoying).
2) A huge part of the delays can indeed be attributed to working with online projects, where it can either due to the server being slow, or due to the communication between the MemoQ client and the client's server being suboptimally configured/managed. I seriously doubt all 5+ of my clients have terrible servers, so as far as I'm concerned, at least half the responsibility for this kind of sluggish performance lies with Kilgray. Even if you have set Sync to manual mode, there's too much of a slowdown while confirming a string to an online TM.

A workaround I've found for those who have an offline license (so surely not needing CAL, but maybe ELM would work) and enough permissions to sync their working project TM for offline use (or just create and use their own) is to block MemoQ from communicating online and then disable the rule to sync progress every now and then. As long as 2+ linguists aren't expected to work simultaneously on time-sensitive tasks, it can result in enormous speed gains. It's great for me, as MemoQ finally manages to catch up to my highest typing speeds when I move from one segment to another. This is extremely important for productivity, especially in projects with shorter strings, like UI localizations.


[Edited at 2020-09-20 21:49 GMT]


 

Evergray
Federación Rusa
Local time: 22:26
No effect Oct 25

Timothy Barton wrote:

Georgios Tziakos wrote:

MemoQ is getting so slow when you scroll up or down the strings in Editor that it basically stutters?


Do you use Firefox? I've found that the slow scrolling magically sorts itself out within about 30 seconds of closing Firefox. If I re-open Firefox, it slows down again. I'm reluctantly considering looking for a new browser if I can't find a fix.

From what I've been reading, it seems that recent (i.e. the past few years) Firefox versions don't work very well with NVidia graphics cards and slow everything down. I've read that rolling back the NVidia driver might help, but haven't tried it yet.

Unfortunately, turning Firefox off didn't help =(
I have MemoQ 9.4 ATM.


 
Páginas sobre el tema:   < [1 2]


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MemoQ 8.+ performance - scrolling up and down oh so tortuously slow

Advanced search






WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Búsqueda de términos
  • Trabajos
  • Foros
  • Multiple search