Directorio mundial de ProZ.com de servicios de traducción
 The translation workplace
Ideas

 
Páginas sobre el tema:   [1 2 3 4] >
Usuario
Autor de la hebra: christenino
Object reference not set to an instance of an object- Studio 2011

christenino  Identity Verified
Austria
Local time: 07:37
inglés al alemán
+ ...
Feb 11, 2012

A good old friend surfacing again...;-)

I have Studio 2011 SP1, Multiterm 2011 SP1 and Trados 2007 Freelance installed on my Laptop.

2007 is working.

2011 turns out to be a nightmare.

As soon as I enter a translation or even when entering a number I get, independently of the file format to be translated (in one case a simple word.doc, in the other case a xml.ttx-file), the error message "Object reference not set to an instance of an object."

What's in the error package?

Here we go:


- Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. - System.NullReferenceException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 Sdl.Desktop.Platform.WinForms -

- SDL Trados Studio 10.0.0.0 10.1.2861.1 Microsoft Windows 7 Home Premium Service Pack 1 1031 1252 TMS-PC\TMS 2.0.50727.5448 TMS-PC True 8298644 MB


That might be very interesting and full uf usable information - regretfully, not for me;-).

May Laptop is a new one, 8 GB RAM, Asus, Intel-Core i5.

Has anbody any idea - or is it better for me to start neverending holidays?

Yes, and I contacted the Support; however, past experiences showed me ...yes, that's the reason I am posting here.

Thanks in advance (even for tips regarding good holiday destinations;-))


Direct link Reply with quote
 

Frankie JB
Francia
Local time: 07:37
Miembro 2011
inglés al francés
+ ...
Solution possibility Feb 11, 2012

Hello christenino,

I am by no means an expert and I don't have Studio 2011 (I have 2009 SP3), but I encountered the same 'problem denomination' 3 days ago (it wasn't the same situation either, as I was importing a project package), but here's how I managed to fix it (I was given the solution, to be honest):

I deleted the XML base settings files

BaseSettings.xml
Plugincache.xml
UserSettings.xml

which are to be found in C:\Users\\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\

then restared, reinstalled some components pretty quickly and then the problem was solved!


Not sure that will work, but who knows?

Good luck anyway!

[Edited at 2012-02-11 12:40 GMT]


Direct link Reply with quote
 

christenino  Identity Verified
Austria
Local time: 07:37
inglés al alemán
+ ...
PERSONA QUE INICIÓ LA HEBRA
Object reference Feb 11, 2012

Hi Frankie,

perfect, it works !!!

Thanks a lot !!!!

Christian


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 07:37
inglés al alemán
+ ...
Happens quite often Feb 12, 2012

and it would be nice if someone from SDL could explain WHY these files tend to get corruped ever so often. I sometimes have to replace these files once a week for various reasons (such as Studio not starting or getting to be very slow etc. ).
I have by now created a folder with backups of the three files with my preferred settings, so that I do not need to "re-set" Studio every time I replace those files. I use these backups every time to "start from scratch".

Surely there must a way to make these files more "robust".

Sanne


Direct link Reply with quote
 
ClareR
Local time: 06:37
Struggling here, would be glad of some advice Feb 16, 2012

Hi everyone

I've been having the same problem, tried closing Trados, reloading orig. file, repopulating and taking off again and hoping for the best. But it's too much of a problem in a large doc. So I tried removing the three files mentioned from the Trados Studio 2011 folder. I removed them to my Desktop, then they popped up in the Trados File again (10.0.0.0 folder) but when I went to open Studio I got the Open for the First Time option. Do I need to go through the whole thing again, or did I do something wrong?

Thanks
Clare


Direct link Reply with quote
 

Anne and Paolo Boidi
Países Bajos
Local time: 07:37
Miembro 2011
italiano al inglés
+ ...
Frankie's solution worked on trados2011 on XP Apr 17, 2012


Frankie J. B. wrote:


I deleted the XML base settings files

BaseSettings.xml
Plugincache.xml
UserSettings.xml

which are to be found in C:\Users\\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\

then restared, reinstalled some components pretty quickly and then the problem was solved!


[Edited at 2012-02-11 12:40 GMT]


Worked for me for Trados 2011 with som slight changes because the AppData folder on XP is under Application Data.

Thank you for your help.




Trados 2011
Windows XP SP3


Direct link Reply with quote
 

Birgit Niederhafner  Identity Verified
Alemania
Local time: 07:37
inglés al alemán
+ ...
Solution worked here as well Apr 22, 2012

Thank you, Frankie, for this great solution.
In my case it worked for Studio 2009 and Windows 7.
Perfect!


Direct link Reply with quote
 
Myrtille Montaud  Identity Verified
Local time: 07:37
Miembro 2010
inglés al francés
+ ...
"reinstalled some components" Apr 24, 2012

Hi everybody,

I have exactly this problem, I would like to follow Frankie's tip, but I fear not to be able to...
Once I have cancelled the 3 xml setting files, which components do I have to reinstall ?

Thanks in advance...


Direct link Reply with quote
 
Zeynep YESIN YALCIN  Identity Verified
Turquía
Local time: 08:37
Miembro 2008
inglés al turco
+ ...
Object reference not set to an instance of an Object - Studio 2009 Jun 11, 2012

Could you please tell me how we can solve this problem for Studio 2009 SP3 running under Vista 7? From which path can we find these 3 files to be deleted? I have searched them, but could not able to find them. Please comment.

Thanks


Direct link Reply with quote
 

Tehsin Begum Mukhtar Ahmad  Identity Verified
Local time: 14:37
Miembro 2006
inglés al malayo
+ ...
Object reference error Studio 2011 Jun 26, 2012

Yes, SDL, PLEASE do help us out here, because trados is supposed to make our life easier, not mess up our deadlines with error messages that only a PHD programmer can understand.

It would help if SDL's error messages were user friendly AND came with an option HOW to solve the problem!

It is getting too much to bear sometimes, because ours is a time sensitive job and because trados has the upper hand, it feels like we are on the losing end of this whole deal.

Please iron out all bugs before we are somewhat forced to buy upgrades!

We would appreciate it very much.

Now I have to go keep restarting studio every few minutes in order to meet my deadline.

Please DO reply, SDL support peeps.

Thanks


Direct link Reply with quote
 

SDL Support  Identity Verified
Local time: 07:37
inglés
On this unhelpful error message Jun 26, 2012

Hi,

The error message itself is quite difficult to decipher because it is an error returned by the application when the value of something it was looking for was null. This value could be anything. Sometimes from the more detailed error stack we can see where the problem may be coming from, but not always. Certainly if there was a consistent way to report exactly what the problem was and how to fix it then we would do.

Sometimes removing the three xml files helps because they have somehow been corrupted and removing them so Studio can regenerate them can be helpful. I don't have a simple answer to how they get corrupted but my guess would be incorrectly shutting down the application or crashing midway are likely candidates.

However, we don't see this type of problem being reported very much any more in Studio 2011.

So, here's how to find them:

Windows XP: C:\Documents and Settings\[USERNAME]\Application Data\SDL\SDL Trados Studio\[10.0.0.0]

Windows Vista/7: C:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\[10.0.0.0]

you delete the following three XML files:

- BaseSettings.xml
- plugincache.xml
- UserSettings.xml

In case you cannot see the "AppData" folder, make sure that your folder view is set to "display hidden system folders. " Here are step-by-step instructions: http://windows.microsoft.com/en-us/windows-vista/Show-hidden-files.

When you delete these and restart Studio it will be as if you are starting for the first time (except for licensing that will not be affected) and you may lose some user settings... you won't lose work as this is all saved as files elsewhere, you may just need to add them back.

If this does not help then you can sometimes resolve a problem (normally an unable to start the application at all problem) by deleting the following file: "projects.xml" located in

Windows XP: C:\Documents and Settings\[USERNAME]Application Data\SDL\SDL Trados Studio

Windows Vista/7: C:\Users\[USERNAME]\Documents\SDL Trados Studio\Projects

Please note that your project list will disappear and you will need to re-open your projects in SDL Trados Studio to have them back in the list. To do this please go to File > Open > Project and browse to the project you wish to open. It will then be added to the Projects list in SDL Trados Studio 2011.

Regards

Paul


Direct link Reply with quote
 

SDL Support  Identity Verified
Local time: 07:37
inglés
If deleting these files doesn't help... Jun 26, 2012

... and you still cannot use Studio then please use the Solution Finder to contact Support and get assistance... with or without a support contract:

Go to the Knowledgebase;

http://kb.sdl.com

Then go to the tab called Solution Finder and follow the route most applicable to the problem you are facing. You will sometimes be prompted with KB articles that can help you to resolve the issue yourself, and if not then at the end of the process you will have an opportunity to complete a form that you can fill in to generate a support request and you will be contacted, normally within a day.

I hope this helps.

Regards

Paul


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 01:37
danés al inglés
+ ...
Try this, it worked for me! Jul 1, 2012

I had the same issue, but it was fixed by following these instructions courtesy of Trados support:


1. Close Studio.

2. Open Windows Explorer and browse to C:\Program Files\SDL\SDL Trados Studio\Studio1\File Types. Copy the entire File Types folder.

3. Now browse to the Studio file types location under the My Documents folder path and paste the entire File Types folder into it.



For Windows XP: C:\Documents and settings\[USERNAME]\My Documents\SDL Trados Studio\File Types

For Windows Vista/7: C:\Users\YNGVE\My Documents\SDL Trados Studio\File Types

 4.  Confirm to replace the folder.

Restart Studio and try to open a file.

---------------

I have now a file, where I can pinpoint the exact TU that causes this message to occur, in fact blocking the Alt+ function from thereon in. What to do about it? You guys tell me

PS. I use Trados SDL Studio 2009 - I just noticed the question pertained to version 2011, but hopefully it'll work regardless.

[Edited at 2012-07-02 18:17 GMT]


Direct link Reply with quote
 

Marc Van Gastel  Identity Verified
Local time: 07:37
Miembro 2006
inglés al neerlandés
+ ...
My solution: try to save the original to an older format Jul 5, 2012

I had same happening in Trados Studio 2011 and Trados 2008 on a source doc that was xlsx, the newer xls format.

I figured it could be an error related to handling the newer MS Office document format, so here are my steps

1/ Saved the XLSX document to the older XLS format with Save As. You should not lose anything if it is one of the "wordy" xls files that we often get for translations in xlsx.

2/ Open the xls file in your version of Trados, then rerun the TM.

3/ Save the target file to xls, open this xls file and save back to the newer xlsx format with Save As. Just deliver the unclean (ttx or sdlxlif) file with the final translation and chances are he won't notice anything at all.

Did it for me. I have also done the same with a PPTX that didn't want to save back to the new file format. It looks like the Trados crooks haven't figured out all the secrets of the new MS file formats yet. The excuses for not solving this are very very lame.

Marc


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
Reino Unido
Local time: 06:37
Miembro 2004
inglés al francés
+ ...
Same error when I tried generating target files - Fixed by removing a comment Aug 9, 2012

Hello

I've just experienced the same issue, in my case when generating my target file.

I tried all the tips suggested in this thread but nothing work.

And then I had the idea to look into the Comments that I inserted in the translation (as I've noticed in the past that they can cause technical issues when exporting/generating target files).

I managed to identify the culprit: a comment which I had inserted (intentionally) on a bit of text within hyperlink tags. As soon as I deleted the comment I was able to generate the target file.

So if you get this error message when exporting or generating target files, I recommend you go through your comments, making sure that no comment range covers tags and/or that they don't get inserted within a hypertext link.

I hope this helps.

Alexa


Direct link Reply with quote
 
Páginas sobre el tema:   [1 2 3 4] >


To report site rules violations or get help, contact a site moderator:

Moderador(es) de este foro
Natalie[Call to this topic]
Myron Netchypor[Call to this topic]
Marco Ramón[Call to this topic]
Maya Gorgoshidze[Call to this topic]
Prachya Mruetusatorn[Call to this topic]

You can also contact site staff by submitting a support request »

Object reference not set to an instance of an object- Studio 2011







SDL Trados Studio 2014 Starter Edition
Translation software for only €99 per year

The Starter Edition is an affordable but scaled down version of the industry’s leading translation software, SDL Trados Studio 2014 Freelance. It enables translators to join the largest supply chain at a reduced price.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexbible, customizable and user-friendly tool on the market. See the brand new features in action: Completely redesigned user interface Live Preview Inline spell checking Inline formatting and more

More info »